View unanswered posts | View active topics It is currently Thu Mar 21, 2019 11:56 am



Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
 utilite getting a serial connection 
Author Message

Joined: Thu Jan 01, 2015 6:03 pm
Posts: 8
Post Re: utilite getting a serial connection
Hi All,

I bought the serial cable recommended above:

http://www.dabs.com/products/startech-c ... tdi&src=16

Now, I should surely have the correct setup. However, I'm getting the same response. When I start minicom, I get absolutley no output. This is the process I am following:

1. Hook up the cables
2. Find cable:
Code:
$ lsusb:
Bus 003 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
$ setserial /dev/ttyUSB0
/dev/ttyUSB0, UART: unknown, Port: 0x0000, IRQ: 0, Flags: low_latency

2. Configure minicom
Code:
  Baud Rate: 115200 8N1
  Serial Device: /dev/ttyUSB0
  Hardware/Software Flow Control: no

3. Power on the utilite
4. Start minicom

Can anyone see anything wrong with this process?

If not, does that mean the utilite is bricked?

Thanks


Tue Feb 10, 2015 7:27 pm
Profile

Joined: Wed May 25, 2011 11:05 am
Posts: 521
Post Re: utilite getting a serial connection
Just checking you are using the front serial socket of utilite, not back


Tue Feb 10, 2015 7:41 pm
Profile

Joined: Thu Jan 01, 2015 6:03 pm
Posts: 8
Post Re: utilite getting a serial connection
Yeah I tried the front initially, then the back and no output from either.

Question: Is it ok to start minicom first, then the utilite? Or should I start the utilite then mincom immediately afterwards?


Tue Feb 10, 2015 7:42 pm
Profile

Joined: Wed May 25, 2011 11:05 am
Posts: 521
Post Re: utilite getting a serial connection
Minicom first. Then when you apply power to utilite messages should flow.
Your usb serial adapter has LEDs? Any blinking?


Tue Feb 10, 2015 9:13 pm
Profile

Joined: Thu Jan 01, 2015 6:03 pm
Posts: 8
Post Re: utilite getting a serial connection
ok yeah i've tried that.. no output.. yes there are LEDs flashing on the adapter


Tue Feb 10, 2015 9:42 pm
Profile

Joined: Thu Jan 01, 2015 6:03 pm
Posts: 8
Post Re: utilite getting a serial connection
i should say, one LED flashes when I hit a key in minicom. But otherwise there aren't any flashing.


Tue Feb 10, 2015 10:17 pm
Profile

Joined: Tue Jan 07, 2014 12:07 am
Posts: 138
Location: Edinburgh, Scotland
Post Re: utilite getting a serial connection
It's probably not minicom's fault but use picocom instead. It's much simpler so less can go wrong.

Code:
picocom -b 115200 /dev/ttyUSB0


Wed Feb 11, 2015 9:31 am
Profile

Joined: Fri Aug 15, 2014 9:57 am
Posts: 37
Post Re: utilite getting a serial connection
Hello !

You can also use/test your serial USB connection on laptop using "screen" program.
You should run the command as "root" user or with "sudo".

The command is "screen /dev/ttyUSB0 115200"

This at the same time gives you writing access to the U-boot interface.
In order to escape from U-boot, just press any key (as it says) within 3 seconds and it brings you to the interface.

Regards,
Jan


Tue Feb 17, 2015 7:25 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.