View unanswered posts | View active topics It is currently Thu Mar 21, 2019 12:00 pm



Reply to topic  [ 10 posts ] 
 Linux 3.18-rc5 broke my Utilite 
Author Message

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Linux 3.18-rc5 broke my Utilite
Hi,

I've been "happily" using my Utilite Standard (fitted with an mSATA SSD) with Ubuntu 14.04.1 and kernel 3.16.7 as a router and firewall for a couple of months. Today I got tired of the Intel I211 hanging for the umpteenth time, and decided to have a go with kernel 3.18-rc5, just to see if any progress had been made in that regard. After building the kernel "as usual" and trying to boot it, it got as far as the U-Boot loading the kernel, and then it got stuck. You know, like it does when there's something wrong with the dtb, for example. So, I simply reverted to my previous known good kernel to get back up again, but this time the Intel I211 network interface does not show up on the PCI bus. Running lspci does not list it any more, and now I'm stuck. I've tried unplugging the Utilite for 5 minutes and plugging it back in; no luck. I have no idea what else to try. Is it possible that I fried my Utilite but just trying to boot Linux 3.18-rc5? Has anyone had any problems with this before? I'm completely at a loss as to how to solve this.

tl;dr Intel I211 network interface does not show up on PCI bus. How do I diagnose and fix this?


Tue Nov 18, 2014 9:09 pm
Profile

Joined: Tue Jan 07, 2014 12:07 am
Posts: 138
Location: Edinburgh, Scotland
Post Re: Linux 3.18-rc5 broke my Utilite
Ouch. I built 3.18-rc5 today but didn't run it yet. I did run a branch based on 3.18-rc4 the other day to test the new DRM GPU driver though. I'm not using the Intel interface at the moment so I wouldn't have noticed but I just booted into 3.10.17 and it's still there. Not sure if it matters but the dts I'm using is probably a bit different to yours as I cherry-picked each of Valentin's commits over a recent kernel and continue to rebase them. I'm afraid I don't know what to suggest.


Tue Nov 18, 2014 10:54 pm
Profile

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Re: Linux 3.18-rc5 broke my Utilite
Ok, so this is getting stranger by the minute. In a last ditch attempt to get it back in working order, booted from the original bundled OS of a Transflash (which I'm right now very happy I had the foresight to dd the first thing I did), and running that kernel (3.0.35-cm-fx6-5.5) shows the I211 network controller on the PCI bus and lets me use it. So, to recap...

I've been running kernel 3.16.x (1-7) for weeks/months. Both network interfaces shows up and can be used.
Trying to boot 3.18.0-rc5 fails, so of course I go back to the 3.16.7 kernel I've been using for weeks. Now, the I211 network interface no longer shows up and can't be used.
Boot from original Utilite Ubuntu software with kernel 3.0.35-cm-fx6-5.5 works, and now both interfaces are back up again. Would continue to use this configuration if it weren't for the constant hangs of the I211 network interface.
Once again I try my known good working 3.16.7 kernel. No go. No I211 network.

How is this even possible?!


Thu Nov 20, 2014 6:32 pm
Profile

Joined: Wed May 25, 2011 11:05 am
Posts: 521
Post Re: Linux 3.18-rc5 broke my Utilite
Was the place that kernel was supposed to be mounted as /boot when you installed kernel?


Thu Nov 20, 2014 7:17 pm
Profile

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Re: Linux 3.18-rc5 broke my Utilite
Yes. I just checked and the /boot directory is empty before mounting the boot partition, and I've set my boot-partition to mount automatically on startup, as I'm a lazy bugger and I know I'd probably forget to mount it the next time I wanted to install a new kernel.

Code:
$ uname -a
Linux fw 3.16.7 #1 SMP Sun Nov 2 14:22:21 CET 2014 armv7l armv7l armv7l GNU/Linux


Code:
$ sudo lspci -v
00:00.0 PCI bridge: Device 16c3:abcd (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Memory at 01000000 (32-bit, non-prefetchable) [size=1M]
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        [virtual] Expansion ROM at 01100000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable+ 64bit+
        Capabilities: [70] Express Root Port (Slot-), MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Kernel driver in use: pcieport


Previously, the I211 would show up there as well, using the same kernel uImage.

I'm thinking that perhaps something in the 3.18-rc5 kernel or the accompanying device tree flipped a switch somehow, and that's whats causing it.


Thu Nov 20, 2014 7:59 pm
Profile

Joined: Mon Oct 13, 2014 6:32 pm
Posts: 14
Location: Lawton, OK
Post Re: Linux 3.18-rc5 broke my Utilite
For kernels that use dts, enough can change from one kernel to another, you always want to replace the dts with the kernel. I suspect that you did this when updating to 3.18, but neglected to do so when reverting back to 3.16.

I have a 3.18-rc5 kernel booted with the pci ethernet working, so it is possible.


Thu Nov 20, 2014 11:16 pm
Profile WWW

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Re: Linux 3.18-rc5 broke my Utilite
But, the dtb is concatenated to the zImage in the uImage. Can it really be using another dtb from another uImage?

Perhaps I should empty my /boot, build another 3.16.7 kernel from the same sources as last time, and install that and see what happens.


Fri Nov 21, 2014 9:09 am
Profile

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Re: Linux 3.18-rc5 broke my Utilite
As expected, building another 3.16.7 with previously known working dts yields no results. For some reason, a configuration that has worked for months no longer does, and I can't for the life of me figure out why.


Sun Nov 23, 2014 11:54 am
Profile

Joined: Fri Aug 15, 2014 9:57 am
Posts: 37
Post Re: Linux 3.18-rc5 broke my Utilite
Hello albatorsk,

Could you maybe provide complete instructions set about how you built 3.16.7 kernel with command line examples ? I would like to try one of the newer kernels for my Utilite Pro.

Regards,
Jan


Wed Feb 18, 2015 8:57 am
Profile

Joined: Tue Aug 12, 2014 5:10 pm
Posts: 21
Post Re: Linux 3.18-rc5 broke my Utilite
I'm sorry, but I've since retired my Utilite as "not fit for purpose".

Maybe I'll dig it out again if CompuLab ever releases a newer working kernel with non-hanging network interface drivers.


Sun Feb 22, 2015 3:23 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.