Utilite & Trim-Slice Users Forum
http://www.compulab.co.il/utilite-computer/forum/

Hardware issues with NAND?
http://www.compulab.co.il/utilite-computer/forum/viewtopic.php?f=63&t=2342
Page 1 of 1

Author:  Gaya [ Thu May 28, 2015 7:50 am ]
Post subject:  Hardware issues with NAND?

Hello,

I got a utilte pro since last year and since the kernel 3.10 was released I can finally use it as AP without crooked USB-wifi dongles (2 network cards make an exceptionable router, but a router without WiFi AP is useless with the amount of mobile devices we have).
Now since I tried again with the kernel and changed the uboot flash to boot from the old kernels as my modified kernel (additionally removed drivers) failed to boot and such I came across an issue that I cannot write to the NAND anymore. Neither from within the OS via fw_setenv now via saveenv in u-boot.
fw_setenv doesn't return anything, fw_printenv returns the old value.
# setenv kernel uImage.new
does the job, saveenv also reports doing its job as it is writing the flash, printenv shows the new value then (as per setenv). After a reset the old value is back (uImage for example, whereas I expected uImage.new).

rgds

Author:  Gaya [ Sun Jun 28, 2015 6:05 pm ]
Post subject:  [SOLVED] Re: Hardware issues with NAND?

Fixed it.
I did a uboot update:
http://www.compulab.co.il/utilite-compu ... oot_Update
From the ubuntu based image I couldn't update at first so I went with the method of booting uboot from the SD-card into my normal system (Gentoo). From there I changed, finally successful, the kernel parameter again. This time it was obviously saved.
Then the updatescript from the utilite ubuntu installation then worked.
Actually it updated the uboot from a 2009-version to a 2014.
Code:
>> Checking for utilities...
>> ...Done
>> Checking that board is CM-FX6 (Utilite)...
>> ...Done
Please input firmware file path (or press ENTER to use "cm-fx6-firmware"):
>> Looking for boot loader image file: cm-fx6-firmware
>> ...Found
>> Looking for SPI flash: mtd0
>> ...Found
>> Current U-Boot version in SPI flash: U-Boot 2009.08-cm-fx6-0.94+tools (Jan 2
>> New U-Boot version in file:          U-Boot 2014.10-cm-fx6-2.2 (May 18 2015
>> Proceed with the update?
1) Yes
2) No
#? 1
** Do not power off or reset your computer!!!
>> Erasing SPI flash...
Erasing 4 Kibyte @ bf000 -- 100 % complete
>> ...Done
>> Writing boot loader to the SPI flash...
...
>> ...Done
>> Checking boot loader in the SPI flash...
.
>> ...Done
>> Boot loader update succeeded!


Actually this helped another issue. I replaced the SSD with another 256GB SSD. Sicne that time the utilite didn't boot without help as it would not recognize the SSD on the SATA port after a cold boot. It would need a "reset" on the serial console to actually boot up. Now i don't need that anymore :)

Author:  AliceSilas [ Mon Apr 15, 2019 7:37 am ]
Post subject:  Re: Hardware issues with NAND?

All the forums of the computer have been met for the future offers. The productivity of the tale and EduBirdie is marked for the humans. The strange element of the computer is removed from the main machine.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/