View unanswered posts | View active topics It is currently Mon Jun 17, 2019 4:50 am



Reply to topic  [ 2 posts ] 
 USB hotplug 
Author Message

Joined: Tue Mar 20, 2012 12:41 pm
Posts: 2
Post USB hotplug
Why all USB devices requires hotpluging? After booting only one device is visible, only that one which was used for booting (SD card or hard disk), all other devices are not usable even if they are properly detected during startup. After removing and inserting again each USB device everything works fine (I have tried this with USB mouse, USB remote control, USB external card reader). Is it something wrong with my trim slice or is it software issue? Any chance to initialize USB devices on startup? I have tried original kernel 1.01 and latest one 2.01, behaviour the same.

BTW. On serial output sometimes I can see some IO errors related to one of USB slots.


Tue Mar 20, 2012 1:20 pm
Profile

Joined: Tue Sep 06, 2011 4:29 pm
Posts: 52
Post Re: USB hotplug
I did get a usb hub for my keyboard and mouse, reason being the usb port where I had my mouse plugged in will go away (never to come back), not sure why the hub prevents this from happening but since it works I didn't dig more into it.


Wed Mar 21, 2012 2:10 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.