View unanswered posts | View active topics It is currently Sun May 19, 2019 6:25 am



Reply to topic  [ 4 posts ] 
 Fedora fails to boot after U-Boot 2012.04 update 
Author Message

Joined: Wed Jul 27, 2011 10:17 pm
Posts: 13
Post Fedora fails to boot after U-Boot 2012.04 update
Is anybody else having issues with the new uboot? After installing the latest version, U-Boot 2012.04.01-1.01 (Aug 01 2012 - 14:33:20), my system no longer boots all the way up. I haven't changed anything but the uboot version. I am not using device tree and the kernels do not have device tree support compiled in. This is using a variety of kernels from the 3.4 and early 3.5 vintage.

If booting from the mmc card the last messages are:
[ 4.670477] Waiting for root device LABEL=rootfs...
[ 4.946037] mmc1: new high speed SDHC card at address 0001
[ 4.953205] mmcblk0: mmc1:0001 00000 7.60 GiB
[ 4.960128] mmcblk0: p1 p2

If booting from the internal drive (this is a trimslice-h): the last messages are:
[ 2.690350] Waiting for root device LABEL=rootfs...
[ 2.807410] usb 2-1: new high-speed USB device number 2 using tegra-ehci
[ 3.168244] usb 2-1: New USB device found, idVendor=148f, idProduct=3070
[ 3.174982] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.182141] usb 2-1: Product: 802.11 n WLAN
[ 3.186348] usb 2-1: Manufacturer: Ralink
[ 3.190383] usb 2-1: SerialNumber: 1.0
[ 3.404287] usb 3-1: new high-speed USB device number 2 using tegra-ehci
[ 3.899662] usb 3-1: New USB device found, idVendor=05e3, idProduct=0718
[ 3.906400] usb 3-1: New USB device strings: Mfr=0, Product=1, SerialNumber=2
[ 3.913560] usb 3-1: Product: USB Storage
[ 3.917948] usb 3-1: SerialNumber: 000000000033

It's as though we're almost passed off to userspace but not quite. Does the new uboot *require* a DTS enabled kernel?


Thu Sep 06, 2012 5:46 pm
Profile

Joined: Wed Jul 27, 2011 10:17 pm
Posts: 13
Post Re: Fedora fails to boot after U-Boot 2012.04 update
By the way, downgrading the the 2010 uboot allows the system to startup successfully. Console logs look like this:

...
[ 3.284941] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[ 3.297523] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 3.305291] hub 1-1:1.0: USB hub found
[ 3.306539] Freeing init memory: 328K
[ 3.312995] hub 1-1:1.0: 4 ports detected
SELinux: unable to find usable policy file: No such file or directory
[ 3.453724] usb 2-1: new high-speed USB device number 2 using tegra-ehci
[ 3.706014] usb 2-1: New USB device found, idVendor=148f, idProduct=3070
[ 3.712756] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.719915] usb 2-1: Product: 802.11 n WLAN
[ 3.724121] usb 2-1: Manufacturer: Ralink
[ 3.728151] usb 2-1: SerialNumber: 1.0
[ 4.042143] usb 3-1: new high-speed USB device number 2 using tegra-ehci
[ 4.438396] systemd[1]: systemd 187 running in system mode. (+PAM +LIBWRAP +)
[ 4.440336] usb 3-1: New USB device found, idVendor=05e3, idProduct=0718
[ 4.440370] usb 3-1: New USB device strings: Mfr=0, Product=1, SerialNumber=2
[ 4.440394] usb 3-1: Product: USB Storage
[ 4.440417] usb 3-1: SerialNumber: 000000000033
[ 4.473196] systemd[1]: Running in initial RAM disk.

Welcome to Fedora 18 (Rawhide) dracut-022-5.git20120723.fc18 (Initramfs)!
...


Thu Sep 06, 2012 10:08 pm
Profile

Joined: Thu May 17, 2012 12:23 am
Posts: 6
Post Re: Fedora fails to boot after U-Boot 2012.04 update
As another data point. I have the same version of u-boot installed on the trimslice:

U-Boot 2012.04.01-1.01 (Aug 01 2012 - 14:33:20)

The machine is succesfully booting a Fedora 17 Kernel 3.5.3-1.fc17.armv7hl.tegra with the filesystems on an SD card.

Brendan, does the f17 kernel work on f18? The f17 kernel might be a work around. Then see what the differences are between the f17 and f18 kernels.


Sat Sep 08, 2012 11:00 pm
Profile

Joined: Wed Jul 27, 2011 10:17 pm
Posts: 13
Post Re: Fedora fails to boot after U-Boot 2012.04 update
Update:

Before 3.7 using the new firmware meant only being able to boot off SD card (internal usb hdd was not found). Starting with 3.7+DTB (Possibly even 3.6+DTB) the new firmware boots on both SD and HDD. The only outstanding issue now is that half the memory is missing.


Fri Jan 25, 2013 10:02 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.