View unanswered posts | View active topics It is currently Sun May 19, 2019 7:09 am



Reply to topic  [ 9 posts ] 
 H250 reboot fails until power cycled 
Author Message

Joined: Fri Nov 11, 2011 8:24 pm
Posts: 2
Post H250 reboot fails until power cycled
When I reboot my TS H250 it never finds
the HD again(until I power off repower up):

/sbin/reboot
...
* Unmounting local filesystems... [ OK ]
* Will now restart
[ 1225.269423] Restarting system.
[ 1225.272565] Restarting Linux version 2.6.38.3-trimslice-1.01-01643-g47e309c (val@devel) (gcc version 4.4.1 (Sourcery G++ Lite 2009q3-67) ) #243 SMP PREEMPT Wed Aug 31 14:23:59 IDT 2011
[ 1225.272620]
...
U-Boot 1.01 (Jul 11 2011 - 17:59:32)

TEGRA2
Board: TrimSlice
DRAM: 1 GiB
SF: Detected W25Q80BL with page size 256, total 1 MiB
In: serial
Out: serial
Err: serial
Boot: Spi
Net: RTL8169#0
Hit any key to stop autoboot: 0
Scanning MMC card ...
[mmc_legacy_init:234] EMMC 0 Probe Failed
No MMC card found
...
(Re)start USB...
USB: Tegra ehci init hccr c5008100 and hcor c5008140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... EHCI timed out on TD - token=0x80008c80

USB device not responding, giving up (status=80000000)
EHCI timed out on TD - token=0x80008c80

USB device not responding, giving up (status=80000000)
2 USB Device(s) found
scanning bus for storage devices... 0 Storage Device(s) found
...
** Block device mmc 1 not supported
Scanning SSD ...
(Re)start USB...
USB: Tegra ehci init hccr c5000100 and hcor c5000140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 2 USB Device(s) found
scanning bus for storage devices... Device NOT ready
Request Sense returned 02 04 01

I suspect that the HD has been spun down ? Is there a procedure to spin up ?

TrimSlice # usb tree

Device Tree:
1 Hub (480 Mb/s, 0mA)
| u-boot EHCI Host Controller
|
+-2 Mass Storage (480 Mb/s, 96mA)
USB Storage 000000000033

Following is whats shown about the devices:
TrimSlice # usb info
1: Hub, USB Revision 2.0
- u-boot EHCI Host Controller
- Class: Hub
- PacketSize: 64 Configurations: 1
- Vendor: 0x0000 Product 0x0000 Version 1.0
Configuration: 1
- Interfaces: 1 Self Powered 0mA
Interface: 0
- Alternate Setting 0, Endpoints: 1
- Class Hub
- Endpoint 1 In Interrupt MaxPacket 8 Interval 255ms

2: Mass Storage, USB Revision 2.0
- USB Storage 000000000033
- Class: (from Interface) Mass Storage
- PacketSize: 64 Configurations: 1
- Vendor: 0x05e3 Product 0x0718 Version 0.21
Configuration: 1
- Interfaces: 1 Self Powered 96mA
Interface: 0
- Alternate Setting 0, Endpoints: 2
- Class Mass Storage, Transp. SCSI, Bulk only
- Endpoint 1 In Bulk MaxPacket 512
- Endpoint 2 Out Bulk MaxPacket 512

Also is there a way to poweroff from the uboot cmd shell?

Chris


Fri Nov 11, 2011 8:58 pm
Profile
Site Admin

Joined: Thu Apr 14, 2011 12:10 pm
Posts: 55
Post Re: H250 reboot fails until power cycled
You can download the latest firmware updater with U-Boot v2009.09-1.02 from the link below:

http://www.trimslice.com/download/firmw ... er.img.zip

The update fixes the issue with HDD detection.


Sun Nov 13, 2011 5:19 pm
Profile

Joined: Fri Nov 11, 2011 8:24 pm
Posts: 2
Post Re: H250 reboot fails until power cycled
Hi,
Hmm thanks but :

[ 191.428043] Restarting system.
[ 191.431290] Restarting Linux version 2.6.38.3-trimslice-1.01-01643-g47e309c (val@devel) (gcc version 4.4.1 (Sourcery G++ Lite 2009q3-67) ) #243 SMP PREEMPT Wed Aug 31 14:23:59 IDT 2011
[ 191.431303]


U-Boot 2010.09-1.02-00003-gee0eedc (Aug 09 2011 - 18:46:07)

TEGRA2
...
Scanning SSD ...
usb1: reset sata controller(Re)start USB...
USB: Tegra ehci init hccr c5000100 and hcor c5000140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 2 USB Device(s) found
scanning bus for storage devices... Device NOT ready
Request Sense returned 02 04 01
0 Storage Device(s) found
...
TrimSlice # usb tree

Device Tree:
1 Hub (480 Mb/s, 0mA)
| u-boot EHCI Host Controller
|
+-2 Mass Storage (480 Mb/s, 96mA)
USB Storage 000000000033

TrimSlice # usb info
1: Hub, USB Revision 2.0
- u-boot EHCI Host Controller
- Class: Hub
- PacketSize: 64 Configurations: 1
- Vendor: 0x0000 Product 0x0000 Version 1.0
Configuration: 1
- Interfaces: 1 Self Powered 0mA
Interface: 0
- Alternate Setting 0, Endpoints: 1
- Class Hub
- Endpoint 1 In Interrupt MaxPacket 8 Interval 255ms

2: Mass Storage, USB Revision 2.0
- USB Storage 000000000033
- Class: (from Interface) Mass Storage
- PacketSize: 64 Configurations: 1
- Vendor: 0x05e3 Product 0x0718 Version 0.21
Configuration: 1
- Interfaces: 1 Self Powered 96mA
Interface: 0
- Alternate Setting 0, Endpoints: 2
- Class Mass Storage, Transp. SCSI, Bulk only
- Endpoint 1 In Bulk MaxPacket 512
- Endpoint 2 Out Bulk MaxPacket 512

TrimSlice #

Still no go.

Chris


Tue Nov 15, 2011 4:21 pm
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: H250 reboot fails until power cycled
ChrisPhi wrote:
Hi,
Hmm thanks but :

[ 191.428043] Restarting system.
[ 191.431290] Restarting Linux version 2.6.38.3-trimslice-1.01-01643-g47e309c (val@devel) (gcc version 4.4.1 (Sourcery G++ Lite 2009q3-67) ) #243 SMP PREEMPT Wed Aug 31 14:23:59 IDT 2011
[ 191.431303]


U-Boot 2010.09-1.02-00003-gee0eedc (Aug 09 2011 - 18:46:07)

TEGRA2
...
Scanning SSD ...
usb1: reset sata controller(Re)start USB...
USB: Tegra ehci init hccr c5000100 and hcor c5000140 hc_length 64
Register 10011 NbrPorts 1
USB EHCI 1.00
scanning bus for devices... 2 USB Device(s) found
scanning bus for storage devices... Device NOT ready
Request Sense returned 02 04 01
0 Storage Device(s) found
...
TrimSlice # usb tree

Device Tree:
1 Hub (480 Mb/s, 0mA)
| u-boot EHCI Host Controller
|
+-2 Mass Storage (480 Mb/s, 96mA)
USB Storage 000000000033

TrimSlice # usb info
1: Hub, USB Revision 2.0
- u-boot EHCI Host Controller
- Class: Hub
- PacketSize: 64 Configurations: 1
- Vendor: 0x0000 Product 0x0000 Version 1.0
Configuration: 1
- Interfaces: 1 Self Powered 0mA
Interface: 0
- Alternate Setting 0, Endpoints: 1
- Class Hub
- Endpoint 1 In Interrupt MaxPacket 8 Interval 255ms

2: Mass Storage, USB Revision 2.0
- USB Storage 000000000033
- Class: (from Interface) Mass Storage
- PacketSize: 64 Configurations: 1
- Vendor: 0x05e3 Product 0x0718 Version 0.21
Configuration: 1
- Interfaces: 1 Self Powered 96mA
Interface: 0
- Alternate Setting 0, Endpoints: 2
- Class Mass Storage, Transp. SCSI, Bulk only
- Endpoint 1 In Bulk MaxPacket 512
- Endpoint 2 Out Bulk MaxPacket 512

TrimSlice #

Still no go.

Chris


Hello Chris,

We got to find an issue you ran into while rebooting the Trim-Slice. The latest u-boot solves the problem. Now, the u-boot also sends a start command to disks in order to spin them in at the very first step of discovering. This fix addresses the sense 2/4/1 issue. Take the latest u-boot version from our ftp.

http://www.trimslice.com/download/dev-private/
user: tsdev
password: cool1way+

Here is a u-boot update procedure:
Copy the U-boot-trimslice-1.03.dd to the root of your usb-disk.
Plug this disk in to the Trim-Slice.
Make the Trim-Slice recognize the usb-disk, type:
usb start 0
Make sure that the usb-disk got recognized and can be red by u-boot, type:
fatls usb 0 # for a vfat-formated device
ext2ls usb 0 # for an ext2/3-formated device
Load the U-boot-trimslice-1.03.dd to the memory:
fatload usb 0 40800000 U-boot-trimslice-1.03.dd # for a vfat-formated device
ext2load usb 0 40800000 U-boot-trimslice-1.03.dd # for an ext2/3-formated device
Burn the spi-flash
sf probe 0 && sf erase 0 100000 && sf write 4080000 0 50000 && saveenv && reset

After reset your Trim-Slice starts using the new u-boot. Let your OS start and reboot. The disk has to get recognized w/o powering the Trim-Slice off/on.

Looking forward to hearing from you whether this u-boot solves the issue with your Trim-Slice.

Good Luck,
Val.


Wed Nov 23, 2011 2:22 pm
Profile

Joined: Mon Sep 26, 2011 11:02 pm
Posts: 4
Post Re: H250 reboot fails until power cycled
Val,

I tried the image you posted (I'm seeing the same problems on my H250, but testing on my Pro) and it bricked my trimslice. Could you verify the image is correct, and post an md5sum of it? (although, it looks like firmware-updater.img has been updated to include that fix anyway, can you confirm this?)

Also, the first time through the *.dd file got compressed by your web server *without* the name changing, which of course *also* bricked my trimslice. Could you please put the image in a zip file to protect it during transfer?

Thanks,
DJ


Tue Jan 03, 2012 9:14 pm
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: H250 reboot fails until power cycled
DJ Delorie wrote:
Val,

I tried the image you posted (I'm seeing the same problems on my H250, but testing on my Pro) and it bricked my trimslice. Could you verify the image is correct, and post an md5sum of it? (although, it looks like firmware-updater.img has been updated to include that fix anyway, can you confirm this?)

Also, the first time through the *.dd file got compressed by your web server *without* the name changing, which of course *also* bricked my trimslice. Could you please put the image in a zip file to protect it during transfer?

Thanks,
DJ


Hello, DJ.

Please use the firmware-updater.img instead of the *.dd. This updater indeed contains the latest fixed u-Boot.

Regards,
Val.


Thu Jan 05, 2012 7:55 am
Profile

Joined: Sun Apr 10, 2011 5:23 am
Posts: 32
Post Re: H250 reboot fails until power cycled
What is the latest uboot "firmware-updater.img" (and where can it be found?) The wiki has a link to 1.01 (which is what the main page links to), the link in here points to 1.02, the .dd file is 1.03, but then it's mentioned that the dd is in the latest img file. Where can that be found?


Mon Apr 23, 2012 4:12 pm
Profile

Joined: Tue Sep 06, 2011 4:29 pm
Posts: 52
Post Re: H250 reboot fails until power cycled
steevatgentoo wrote:
What is the latest uboot "firmware-updater.img" (and where can it be found?) The wiki has a link to 1.01 (which is what the main page links to), the link in here points to 1.02, the .dd file is 1.03, but then it's mentioned that the dd is in the latest img file. Where can that be found?


As far as I can tell the wiki page (http://www.trimslice.com/wiki/index.php/Firmware_Update) points to 1.03 http://www.trimslice.com/download/firmw ... er.img.zip

on your serial tty output you should see this:

U-Boot 2010.09-1.03-00006-ga52694f (Nov 24 2011 - 10:41:33)

Edit: If you want more information about building your own firmware there are some links on this topic reply:
viewtopic.php?f=15&t=502&p=2274#p2274


Mon Apr 23, 2012 6:43 pm
Profile

Joined: Sun Apr 10, 2011 5:23 am
Posts: 32
Post Re: H250 reboot fails until power cycled
I meant this page: http://trimslice.com/wiki/index.php/Download which is pointed to from the main http://trimslice.com site for Downloads links to 1.0.1; That is why I was confused. After a bit of searching I ended up on the site you linked and found the 1.0.3 and I'm happily up and running it. I know how to build u-boot myself, but I prefer not to compile it myself for the time being.


Mon Apr 23, 2012 9:25 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.