View unanswered posts | View active topics It is currently Thu Mar 21, 2019 11:32 am



Reply to topic  [ 14 posts ]  Go to page 1, 2  Next
 Serial Port not Reading/Writing 
Author Message

Joined: Mon Jul 18, 2011 2:51 am
Posts: 7
Post Serial Port not Reading/Writing
Hi All,

I'm not receiving any output on the serial port at any time during the boot process at any stage. I'm using the COM port on the front of the trimslice.

Writing to the serial port while in the kernel using cu and minicom also produces no output.

Has anyone had this issue, and managed to resolve it?

Thanks
Seb


Mon Jul 18, 2011 2:55 am
Profile
Site Admin

Joined: Sun Mar 13, 2011 11:52 am
Posts: 390
Post Re: Serial Port not Reading/Writing
(a) Do you have any other boot indications (monitor activity)?
(b) What COM port settings do you use?

_________________
---------------------------
Igor Vaisbein
Utilite Product Manager

---------------------------


Mon Jul 18, 2011 7:02 am
Profile

Joined: Mon Jul 18, 2011 2:51 am
Posts: 7
Post Re: Serial Port not Reading/Writing
We are using the settings given in the docs (115200 8N1) with a null modem cable and this occurs if we have booted fully into the default Ubuntu install without any output.

However, now, we cannot go past the stage where there is a single cursor icon (rectangle at top left of screen) on the dvi output, which I believe means we are stuck in u-boot and we need to access the serial output.

We tested on several PC's while it was working, and none of them gave any output on the serial cable.


Mon Jul 18, 2011 8:13 am
Profile
Site Admin

Joined: Sun Mar 13, 2011 11:52 am
Posts: 390
Post Re: Serial Port not Reading/Writing
Please make sure that your serial port setup disables all flow control (SW and HW) options and that carrier detection is also disabled.

_________________
---------------------------
Igor Vaisbein
Utilite Product Manager

---------------------------


Mon Jul 18, 2011 10:00 am
Profile

Joined: Mon Jul 18, 2011 2:51 am
Posts: 7
Post Re: Serial Port not Reading/Writing
I will double check that tomorrow, but we have been using a null modem cable, which, if I am not mistaken, should set those values correctly...

Thanks for your help, and I'll let you know how that goes.


Mon Jul 18, 2011 10:55 am
Profile

Joined: Wed May 25, 2011 11:05 am
Posts: 521
Post Re: Serial Port not Reading/Writing
A null modem cable basically crosses rx to tx, and tx to rx (and possibly a few more), no hardware inside except wires. Been messing with these things when 300 baud was leading edge.


Mon Jul 18, 2011 12:40 pm
Profile

Joined: Tue Apr 19, 2011 8:50 pm
Posts: 5
Post Re: Serial Port not Reading/Writing
pepedog wrote:
A null modem cable basically crosses rx to tx, and tx to rx (and possibly a few more), no hardware inside except wires. Been messing with these things when 300 baud was leading edge.


I confirm, you should cross rx and tx, I built my own adapter with a soldering iron. Only 3 pins are used, see: http://www.lammertbies.nl/comm/info/RS-232_null_modem.html#noha.

I accessed the serial port with the screen command
Code:
screen /dev/ttyUSB0 115200,cs8,-ixon,-ixoff

you close this terminal with Ctrl-a d (man screen).


Mon Jul 18, 2011 11:14 pm
Profile

Joined: Mon Jul 18, 2011 2:51 am
Posts: 7
Post Re: Serial Port not Reading/Writing
Hi,

I'm still not getting any output on the serial port. I have definitely disabled both hardware and software flow control and carrier detection is off.

I have tested on a number of cables and a number of computers.

On screen, the DVI port shows a blank screen with the rectangle cursor icon in the top left, and the HDMI port is blank.

Is there anything else I can try?

Thanks


Tue Jul 19, 2011 2:40 am
Profile
Site Admin

Joined: Sun Mar 13, 2011 11:52 am
Posts: 390
Post Re: Serial Port not Reading/Writing
Please perform the firmware update procedure as described at http://trimslice.com/wiki/index.php/Firmware_Update

_________________
---------------------------
Igor Vaisbein
Utilite Product Manager

---------------------------


Tue Jul 19, 2011 6:36 am
Profile

Joined: Wed Sep 07, 2011 9:41 am
Posts: 2
Post Re: Serial Port not Reading/Writing
I had a similar problem, and indeed, updating the U-Boot image fixed it. The strange thing is that I plugged it into my serial port, and got output once... but from then on, it would not speak to me again. Booting off my recovery SD, it happily went back to talking to me, though.

So, the moral of the story is, even if it seems like things are hardware sorts of broken, and even if you've done the recovery boot once and reimaged it once, do it again, and maybe it will speak to you this time. Thanks, Igor.


Fri Sep 09, 2011 9:24 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.