View unanswered posts | View active topics It is currently Thu Mar 21, 2019 11:45 am



Reply to topic  [ 13 posts ]  Go to page Previous  1, 2
 [solved] u-boot 2012.04 - half sized memory 
Author Message

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: u-boot 2012.04 - half sized memory
mozes wrote:
valentin wrote:
The half-size issue has been fixed.
You are welcome to try it out.
Gitorius has been updated as well, here is the link:

https://gitorious.org/trimslice-u-boot- ... .04-upload

Regards,
Valentin.


Has anybody tried this?

I took the archive from https://gitorious.org/trimslice-u-boot- ... .04-upload

built u-boot natively, then built the final image on an x86_64 machine since the binary in the scripts repo (git://gitorious.org/cbootimage/cbootimage-scripts.git) is for x86, and installed the new firmware file.

The Trimslice now boots and hangs at:
Code:

U-Boot 2012.04.01-1.01 (Mar 18 2013 - 14:32:38)

TEGRA2
Board: Compulab Trimslice
DRAM:  1 GiB
MMC:   Tegra2 SD/MMC: 0, Tegra2 SD/MMC: 1
SF: Detected W25Q80BL with page size 4 KiB, total 1 MiB
In:    serial
Out:   serial
Err:   serial
Net:   PCI device RTL8169#0: unknown chip version, assuming RTL-8169
PCI device: TxConfig = 0x2B1000C0
RTL8169#0
Hit any key to stop autoboot:  0
(Re)start USB...
USB:   Register 10011 NbrPorts 1


Does anybody have a working binary I can use?


Take the latest u-boot updater:
http://trimslice.com/download/firmware- ... 02.img.zip

and follow instruction on this page:
http://www.trimslice.com/wiki/index.php ... TS_support


Mon Apr 08, 2013 8:07 am
Profile

Joined: Sun Nov 27, 2011 11:44 am
Posts: 18
Post Re: u-boot 2012.04 - half sized memory
valentin wrote:


I found that binary last week and tried it. It gets further than the version I compiled, but it cannot boot either my Slackware kernel, and it seems Fedora users are having trouble too:
viewtopic.php?f=37&t=1218


Mon Apr 08, 2013 8:23 am
Profile

Joined: Mon Jul 25, 2011 2:35 pm
Posts: 445
Post Re: u-boot 2012.04 - half sized memory
The problem has been found. It was a kernel panic caused by incorrect DTB relocation by U-Boot. The fix is pretty simple and requires no code changes.

While in U-Boot issue these commands:
setenv fdt_high 0x2C000000
setenv initrd_high 0x2C000000
saveenv
reset

The Trim-Slice Firmware Updater page has been updated as well:
http://www.trimslice.com/wiki/index.php ... TS_support


Mon Apr 08, 2013 2:32 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 13 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.