View unanswered posts | View active topics It is currently Wed Jan 23, 2019 12:58 am



Reply to topic  [ 6 posts ] 
 Anyone running the bare bones version? Filesystem issues? 
Author Message

Joined: Sat Apr 14, 2012 1:58 am
Posts: 22
Post Anyone running the bare bones version? Filesystem issues?
Nearly everything I run across is on the version with the internal SSD. I'm wondering if anyone is running the barebones and using an internal micro SD or regular SD in the front slot as your system.

I have tried both, with the earlier natty install, and the more recent OS as well. In both cases, after running for about a day, lots of problems crop up. Pulling the memory card and fsck on my desktop reveals LOTS of filesystem errors, corrupted directories, etc.

I also noted, while running the unit, that I/O wait times are terrible! It feels slower than running a system on a card reader with USB 1.0. I can't imagine anyone could work reliably with the device if this behavior is consistent.

I see in downloads that there is a firmware file, but I'm not sure about versions. There is no clear indication as to what version it is, or how to tell what version I'm running. Maybe I'll hook up the serial and see if something in the output during power on will clear that up. I don't even know at this point if the file system destruction is due to firmware bugs, kernel problems, or hardware problems..

Is anyone else running bare bones that can chime in here?


Thu Apr 19, 2012 10:30 pm
Profile

Joined: Thu Sep 15, 2011 5:22 pm
Posts: 7
Post Re: Anyone running the bare bones version? Filesystem issue
I'm also running the bare bones version here. I've noticed that running the OS (I'm using Arch Linux ARM) is very slow from the SD cards (micro and normal) so I switched over to running the OS on a external USB hard drive which provides much better performance.

When running off of the SD card I also was getting lots of filesystem errors but never figured out why.


Fri Apr 20, 2012 12:09 pm
Profile

Joined: Tue Sep 06, 2011 4:29 pm
Posts: 52
Post Re: Anyone running the bare bones version? Filesystem issue
I don't have a bare bones system but maybe this helps.

The latest firmware should say, over the serial tty when you power it up:

Code:
U-Boot 2010.09-1.03-00006-ga52694f (Nov 24 2011 - 10:41:33)

TEGRA2
Board:   TrimSlice
DRAM:  1 GiB
SF: Detected W25Q80BL with page size 256, total 1 MiB
In:    serial
Out:   serial
Err:   serial
Boot:  Spi
Net:   RTL8169#0
Hit any key to stop autoboot:  0
TrimSlice #

Note that I did hit a key to stop the boot process.
Information about u-Boot commands can be found at:
http://www.trimslice.com/wiki/index.php ... ice_U-Boot &
http://www.denx.de/wiki/U-Boot/Documentation

The latest version of the firmware is 1.03 as it shows above, the page with instructions and where to get the latest firmware is at:
http://www.trimslice.com/wiki/index.php/Firmware_Update

The change log doesn't specify anything about the SD cards but it doesn't hurt to get the latest firmware.

When booting from the firmware update card it should start flashing the front leds around the power button on and off when it's done updating the firmware.

On the performance of the SD card, the media itself might have an impact, a class 10 might help but I use class 4 cards and don't run into corruption issues but I don't boot from the SD card that often, only when debugging a new kernel.

But the file system itself has remained unchanged on that card and no corruptions on it so far, although sometimes after copying a new kernel, the sync before unmounting the card from my host computer takes a while.

If you want information about firmware creation check:
http://www.trimslice.com/wiki/index.php ... e_Creation

I truly hope it's as simple as updating your firmware to 1.03 :)


Fri Apr 20, 2012 5:57 pm
Profile

Joined: Sat Apr 14, 2012 1:58 am
Posts: 22
Post Re: Anyone running the bare bones version? Filesystem issue
Well, I did update the firmware to 1.03. I could never get it to boot off an external USB drive previously, so I had hopes that this would resolve that problem. I burned the natty install image to an 8Gig SD and booted it. Plugged in a 60G external laptop HD and started the installer.

It gets to some random point of extracting the archive to the external drive and fails with a "failed to write" error. Same thing happens if I try to use an USB thumb drive. Tried four times. Once it made it to 78% on extraction before failing, once only 15%.

The more recent installer based on ubuntu 11 does install, but fails to complete a boot off the external drive.

Had a friend send me info on slackware on the trim slice, might try that next. I've had it for a week, and all I've been trying to do is get a stable OS on the bloody thing.


Sat Apr 21, 2012 1:57 pm
Profile

Joined: Sat Apr 14, 2012 1:58 am
Posts: 22
Post Re: Anyone running the bare bones version? Filesystem issue
More info:

Reading through the post I have on getting slackware on the thing, the author points out that he has continual problems with random USB bus resets while running. This seems to be what I'm seeing when trying to install the natty image to an external HD. I plugged in a usb hub I have that blinks when it gets reset, and saw it blinking each time the installer hesitated while unpacking. Eventually the usb reset causes the unpack to fail.

I came back here and found some other threads about USB resets. This could also be the core of the problem I've had with filesystems getting corrupted. If random USB resets are happening while running, and they interrupt writes to the disk or SD card, they could be the cause.

So now I need to find if there's a way to prevent the resets from occurring.


Sat Apr 21, 2012 2:10 pm
Profile

Joined: Wed Oct 19, 2011 8:46 pm
Posts: 3
Post Re: Anyone running the bare bones version? Filesystem issue
I only wanted to mention that I also got file corruption errors on the internal micro SD card. After struggling with it a lot of times (repairing it with a desktop pc and fsck) I finally bought a Intel DN2800MT and now I got a Trimslice left that is searching for further use cases.


Thu Jun 21, 2012 2:47 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.